Polaroid SX-70 problem

Discussions on the SX-70 and the entire series 500, 1000, 2000 ...
skd80
P.......
Messages : 2
Inscription : lun. 31 mars 2014 / 22:00 pm

Polaroid SX-70 problem

Messagepar skd80 » lun. 31 mars 2014 / 22:04 pm

Hi! I newbie in photography, buy on ebay Polaroid SX-70 camera, but camera dont work.
Dont ejecting film after i push the button, but when I insert fresh pack of film from impossible camera always ejecting first dark protection film.
When I push button camera make a sound ( https://www.youtube.com/watch?v=Oqy6...ature=youtu.be) and dont ejecting film. Objective dark becouse shutter is closed. When reinstall film pack, shutter are open. Tell me, can I repair this problem?
Thx.
SX-70

skd80
P.......
Messages : 2
Inscription : lun. 31 mars 2014 / 22:00 pm

Messagepar skd80 » lun. 31 mars 2014 / 22:27 pm

Little update: sometimes camera work! But I dont understand principle of work, sometimes insert film and camera work, but predominantly camera dont work,
Im in perplexity...
SX-70

Avatar de l’utilisateur
jonrev
Pol.....
Messages : 76
Inscription : ven. 18 octobre 2013 / 21:32 pm
Localisation : Grayslake, IL USA
Contact :

Messagepar jonrev » mar. 01 avril 2014 / 09:48 am

Ejects darkslide, shutter closes, but mirror doesn't slap and expose the film, right? Probably switch failure - in the right hands it's repairable.


Revenir vers « Polaroid® SX-70 & 1000, 2000... Land Camera »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité