"The Button" Camera - problem with shutter button

Discussions on the SX-70 and the entire series 500, 1000, 2000 ...
claire00
P.......
Messages : 2
Inscription : dim. 24 décembre 2017 / 20:13 pm
Contact :

"The Button" Camera - problem with shutter button

Messagepar claire00 » dim. 24 décembre 2017 / 20:30 pm

Hi everyone,

I am new to Polaroid. I have received a Polaroid The Button (SX-70 format) as a present but I can't make it work.

When I insert new film (I got some new Color SX-70 Film from the Impossible Project) it ejectes the first card, but then the shutter button remain stuck in the "pressed" position with the shutter closed and it's impossible to make it move anymore.
I tried taking out all the film (in a completely dark room) and putting it back again, but it immediately started ejecting all the films one after the other. Then the button remains stuck in the same "pressed" position.
Is there something I can do?
Also, inserting and removing the film is quite difficult, you have to push it in very strongly.

Thank you for reading this,

Chiara

Avatar de l’utilisateur
bimo
Polaroid 20x24
Messages : 6405
Inscription : mar. 06 avril 2010 / 17:58 pm
Localisation : Paris
Voir la galerie photo de ce membre

Messagepar bimo » lun. 25 décembre 2017 / 11:45 am

Ciao Chiara,

Unfortunately, these cameras are old (like more than 30 years), and although some are in a perfect shape, there might be a problem with some parts and/or components for some of them.

I think the best thing to do is not to spend money and time on a repair for that button, just a few people can nowadays deal with these cameras. I know it has been a present but you can find quite easily a replacement camera, there are a lot of Polaroid cameras to find on second hand websites.


Revenir vers « Polaroid® SX-70 & 1000, 2000... Land Camera »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité