SX_70 withe photos

Discussions on the SX-70 and the entire series 500, 1000, 2000 ...
Leo Micoli
P.......
Posts: 1
Joined: Sun 06 May 2018 / 12:34 pm

SX_70 withe photos

Postby Leo Micoli » Sun 06 May 2018 / 12:57 pm

Hello, I both few months ago a camera SX-70 on ebay. I put a film B&W IMPOSSIBLE INSTANT FILM 600. But all my 8 pictures are white. I thought it was the pack had a problem. I put an another film POLAROID B&W SX_70. I took one picture and the result is the same. Some one have an idea what could be the problem?

User avatar
CCédric
Polaroid 600SE
Posts: 3318
Joined: Thu 12 June 2014 / 23:50 pm
Location: Annecy
Flickr: priorite-ouverture
Contact:
Voir la galerie photo de ce membre

Postby CCédric » Sun 06 May 2018 / 14:34 pm

Hello,
Did you place the film under the light ?
Les instantanés, c'est sur PP. Mes autres photos sont ici : http://ccedric.com

De toute façon, "toutes les images disparaîtront." A. Ernaux, Les Années

scapy
P.......
Posts: 1
Joined: Wed 30 May 2018 / 17:19 pm

Postby scapy » Wed 30 May 2018 / 17:22 pm

Hi,

I have the same issue, and don't know to resolve.
You have any resolution?

User avatar
Meaulne
Konica Instant Press
Posts: 5880
Joined: Mon 04 May 2009 / 23:53 pm
Location: RP SO
Voir la galerie photo de ce membre

Postby Meaulne » Thu 31 May 2018 / 10:47 am

I faced same issue on a 680, it was because the shutter stayed wide open during all the mirror cycle ...
Impossible fixed that for about 75 or 90 €(dont remember exactly)
Comme sur les sites de vielles bagnoles ... on sait bien que maintenant y'a mieux...
Mais question Radio je reste Fidel à ....
https://www.radiobeton.com/www/

User avatar
mimi_club
Po......
Posts: 45
Joined: Sat 26 December 2015 / 14:14 pm
Location: British-Hong Kong
Voir la galerie photo de ce membre

Postby mimi_club » Mon 04 June 2018 / 19:49 pm

Keep your white photos for test.

I think that you may try to put the camera at a dry cool place.
Put the white photos back into the photo cartridge.

just try to see if the aperture/shutter will open-and-close or not.
Try some more cycles. Something it may stuck for no reason.
China(支那)-occupied-Hong Kong


Return to “Polaroid® SX-70 & 1000, 2000... Land Camera”

Who is online

Users browsing this forum: No registered users and 9 guests