Polaroid 600 Impulse Camera Problem with the development

Discussions on using Polaroid® 600 Camera: Spirit, Impulse, Supercolor, OneStep, 680 SLR ...
polaroid 600 Impulse
P.......
Posts: 3
Joined: Wed 26 August 2015 / 12:02 pm

Polaroid 600 Impulse Camera Problem with the development

Postby polaroid 600 Impulse » Wed 26 August 2015 / 12:31 pm

Hey Guys!
i've got a problem with the development of the instant film. I bought this film on amazon.

http://www.amazon.de/Impossible-3220-So ... d+600+film

2 of 8 pics were good, but the other ones came out very badly. So i wrote to the seller and asked, if the film was stored correctly. I asked if the film was damaged. They answered, that the pressure rollers do not work correctly, so the picture could not develop correctly. The chemical elements of the film could not spread constantly so the pic came out blank.

Is there anybody who knows something about the pressure rolls? Is it possible to change or repair them? Or is that the dead of my camera?

Thanks for your answers and help

Best regards
Laura

User avatar
jonrev
Pol.....
Posts: 76
Joined: Fri 18 October 2013 / 21:32 pm
Location: Grayslake, IL USA
Contact:

Postby jonrev » Sun 30 August 2015 / 10:36 am

Define "very badly". If you have bad roller pressure, you'll have goldish-brown areas on at least a third of your image or so. If you're getting completely washed-out (white) images: more than likely you're not shielding the image from light when it ejects. Impossible's color film still has this issue, black and white "Gen-2" doesn't.

polaroid 600 Impulse
P.......
Posts: 3
Joined: Wed 26 August 2015 / 12:02 pm

Postby polaroid 600 Impulse » Sun 30 August 2015 / 18:04 pm

Hey jonrev!
Thx for your answer. I am not able to attache a picture.... there is the link to my assessment :) there is a foto of the 3 worst pitctures...

http://www.amazon.de/review/R296QOLMTJS ... tore=photo

The confusing thing is, that I had no problem with the film I used before. This was Impossible PX 680 Color Protection and all of them were without mistakes.


best regards

rocker
P.......
Posts: 1
Joined: Mon 16 May 2016 / 09:26 am

Postby rocker » Mon 16 May 2016 / 09:31 am

hello it's my first time hear so lease be patient.
I've just bought a Polaroid 636.
I also bought a film with expired date April 2016 and when i shoot pics this what have after 3 hours of development.
https://naforum.zapodaj.net/89c11269dca6.jpg.html
could please help solve this case. Were the chemicals on film to old (sotrage in cold conditions) or it's a problem with camera?


Return to “Polaroid® 600 Series”

Who is online

Users browsing this forum: No registered users and 1 guest