Page 1 sur 1

Is my Polaroid 600 Sun LMS dead?

Publié : dim. 16 avril 2017 / 18:33 pm
par andreiabc
So... I bought this camera on ebay... I pretty much found it no so expensive and in pretty good cosmetic shape, with the original box and some cool manuals and brochures. Buyer said that when he inserts an old cartridge, the camera makes noise and the light was on, so I thought it will work. When it arrives, I tested it with that cartridge and the camera made the noise and the light was on, so I bought one Impossible Project film.

When I inserted this new film the camera didn't show any signs of life :lol: Well, I was pissed off, since my previous experience with the IP film wasn't the best. I thought that the battery of the cartridge was dead but... now I tested with the old cartridge and the camera didn't make any noise either.

So, I looked inside the camera. Everything looks out of corrosion but I tried to clean it. I also cleaned the rollers. Then I inserted both films and the camera made the noises again but... on the IP film the dark slide does't came out. I can hear the motor working, but it seems that it isn't able to eject anything. Also, I tried to take a picture and the flash fired all the times, so maybe this is not a battery problem. :?:

Now what? Is my camera dead? Can it be some sort of bad connection between the batteries and the camera? Maybe some problem with the ejection system? Both? :|

Publié : dim. 16 avril 2017 / 20:26 pm
par scaf
Hi,

I think it might be a gears problem.
After shooting, if you open the "hatch" with the rollers and look at the cartridge, do a film seem to have "popped out", began to eject ?
If yes, it may be the rollers that can't catch the film.
If not, it may be the early ejection mechanism to be blamed.

More info in this file : http://nebulus.zapto.org/~obordron/anciensite/photos/pola/Documents/SX-70%20Troubleshooting%20(Public).pdf
It's not the same pola but the ejection mechanism is mostly the same. Chapter 5 page 7.

Publié : dim. 16 avril 2017 / 23:19 pm
par andreiabc
Hum, no, the film doesn't seem to move... :(

Thanks for the documentation, but I can't open the link. It says 404 Not Found... :|

Publié : lun. 17 avril 2017 / 08:14 am
par scaf
OK, link restored :).

Publié : lun. 17 avril 2017 / 15:34 pm
par andreiabc
Thanks!

Well, the document isn't clear about the issue of not ejecting the dark slide, but from what I understand, it seems that the camera isn't able to pick to move the film? :(